• ConCor MP15 lacks pulling power

  • Discussion related to everything about model railroading, from layout design and planning, to reviews of related model tools and equipment. Discussion includes O, S, HO, N and Z, as well as narrow gauge topics. Also includes discussion of traditional "toy train" and "collector" topics such as Lionel, American Flyer, Marx, and others. Also includes discussion of outdoor garden railways and live steamers.
Discussion related to everything about model railroading, from layout design and planning, to reviews of related model tools and equipment. Discussion includes O, S, HO, N and Z, as well as narrow gauge topics. Also includes discussion of traditional "toy train" and "collector" topics such as Lionel, American Flyer, Marx, and others. Also includes discussion of outdoor garden railways and live steamers.

Moderators: 3rdrail, Otto Vondrak, stilson4283

  by BobLI
 
This engine has never had pulling power. It stalls out with only 8 cars being pulled. All 8 wheels turn and pull but it just seems very light weight. My blue box athearn sw1500 out pulls it by a lot. Any suggestions to add weight or should I try to use that bullfrog snot on 2 wheels?
  by Backshophoss
 
Believe the Con-cor MP15 was a Kato design clone,might be missing some of the factory weight,would try the "bullfrog snot" as the quick fix.
Is this on level track,or on any kind of grade?
  by Backshophoss
 
There's little room for extra weight(can barely install a "lightboard" decoder),so it's the snot as the fix for now.